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Introduction

The Apache JMetexr™ is pure Java open

source software, which was first developed by Stefano
Mazzocchi of the Apache Software Foundation,
designed to load test functional behavior and measure
performance.

Apache Jmeter is a popular open source performance
testing tool.
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https://www.guru99.com/java-tutorial.html
https://www.guru99.com/apache.html

Why JMeter?

Pecause it's a

Why should | use powerful tool
JMeter for my testing . with enormous
testing

capabilities
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Jmeter Advantages JM eter”

Apach

Je

Open source license Friendly GUI Platform independent
Full multi-threading B i .
o Visualize Test Result Easy installation
2 - Unlimited testing ;
Highly extensible ospiliilics Support multi protocol
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JMeter Advantages / ji\Aleéter
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code for the development

v Friendly GUI: JMeter is extremely easy to use and doesn't take time to get
familiar with it

v Platform independent: J[Meter is 100% pure Java desktop application. So it
can run on multiple platforms

v Full multithreading framework. [Meter allows concurrent and simultaneous
sampling of different functions by a separate thread group

v Visualize Test Result: Test result can be displayed in a different format such
as chart, table, tree and log file

v Easy installation: You just copy and run the *.bat file to run JMeter. No
installation needed.
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JMeter Advantages (continue) JMeter“"

v" Highly Extensible: You can write your own tests. JMeter also supports

visualization plugins allow you to extend your testing

v Multiple testing strateqgy: J[Meter supports many testing strategies such
as Load Testing, Distributed Testing, and Functional Testing.

v Simulation: JMeter can simulate multiple users with concurrent threads, create
a heavy load against web application under test

v Support multi-protocol: JMeter does not only support web application testing
but also evaluate database server performance. All basic protocols such as HTTP,
JDBC, LDAP, SOAP, JMS, and FTP are supported by J[Meter

v" Record & Playback - Record the user activity on the browser and simulate
them in a web application using JMeter

v" Script Test: Jmeter can be integrated with Bean Shell & Selenium for automated

testini



https://www.guru99.com/load-testing-tutorial.html
https://www.guru99.com/functional-testing.html
https://www.guru99.com/selenium-tutorial.html

How [IVMIeter Works

Test report

R et

T c

Create request
to target server

Jmeter simulotes

Collect and mu-/t/'p/e users
it sendirng reguesét to Server
| calculiaie ‘ torget server, ond responds

\ returms the

~ statistical info

performance result .
of the torgeé

Saves all

responses MyTCf“:: E
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OS Support For JMeter

JMeter is a pure Java application and should run correctly on any system that has a

compatible Java implementation.

Here is the list of an operating system compatible with JMeter

e | inux

e Windows
e Mac OS
e Ubuntu
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JMeter Elements: Thread Group, Samplers, Listeners,
Configuration

What is Element in JMeter?

JMETER

Thread Group

o i e |
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Controller




Thread Group

Thread Groups is a collection of Threads. Each thread represents one user using the
application under test. Basically, each Thread simulates one real user request to the server.

The controls for a thread group allow you to Set the number of threads for each group.

For example, if you set the number of threads as 100; JMeter will create and simulate 100
user requests to the server under test

user |
Simulates ' Request 1
— | domem— »
Simulates Request 2 By
— — [
t‘ Thread Group |— e
mulates
user | ' > User 2 S—
....... =
Request 100
Simulates ,
> =

»
App\'\caiion under Test
User 100




Samplers

As we know already that JMeter supports testing HTTP, FTP, JDBC and many other protocols.
We already know that Thread Groups simulate user request to the server

But how does a Thread Group know which type of requests (HTTP, FTP etc.) it needs to
make?

The answer is Samplers

The user request could be FTP Request, HTTP Request, JDBC Request...Etc.

Samplers

I T 1
' FTP Request \ 'H’ITPRequst\ 'J‘DBCReque:tl ' BSF Sampler \ ' Agg;’;;’;‘r’ﬁ \ 'SMTPSm;le:\




HTTP request:

This sampler lets you send an HTTP/HTTPS request to a web server.

Consider the example below. JMeter sends an HTTP request to Google website and retrieve

HTML files or image from this website.

sendan HTTP request

—— ©Google

return HTML, images




Listeners

Listeners: shows the results of the test execution. They can show results in a different format
such as a tree, table, graph or log file

L L TOTAL LR J 22 n

Graph Table Tree Log




Graph result listeners display the server response times on a Graph

Graphs to Display Data Average Median Deviation Throughput

2238 ms I—

Oms |4 l Il
No of Samples 25092 Latest Sample 527 Average 1369
Deviation 2922 Throughput 34 168/minute Median 989



View Result Tree show results of the user request in basic HTML format

View Results Tree

Name: |Vi ew Results Tree

Comments:
Write results to file /| Read from file

Filename | | Browse.. | Log/Display Only: | |Errors | | Success
o Login as u1 ‘|[ Sampler result | Request | Response data
&4 Action = none i
&4 Action a Sample Start: 2013-08-26 13:42.57 ICT
&4 Action b Load time: 273
&4 Action c Latency: 0
&4 Action d Size in bytes: 15
&4 Logout Headers size in bytes: 0

Body size in bytes: 15
Sample Count: 1

Error Count: 0

Response code: 200
Response message: OK

&4 Action = <EOF=
&4 Login as u2

&4 Action = none
&4 Logout

&4 Action = <EOF=




Table Result show summary of a test result in table format

View Results in Table
Name: ‘View Results in Table
Comments:
Write results to file / Read from file
Filename ‘ Browse.. | Log/[
Sample # Start Time Thread Name Label Sample Time(ms)
1 11:20:29.282|Thread Group 1-1 |HTTP Request 1430
2 11:20:31.714|Thread Group 1-1 |HTTP Request 1490
3 11:20:34.206|Thread Group 1-1 |HTTP Request 534
4 11:20:35.743|Thread Group 1-1 |HTTP Request 1966
5 11:20:38.714|Thread Group 1-1 |HTTP Request 1247
6 11:20:40.964|Thread Group 1-1 |HTTP Request 1140
7 11:20:43.107|Thread Group 1-1 |HTTP Request 1631
8 11:20:45.740|Thread Group 1-1 |HTTP Request 683




Log show summary of a test results in the text file

samgler label !aggregate_ average aggregate.

/vBexp3/redir_ html 187 3517 185
/vbexp3/iframe htrr 168 1595 165
/first-android-testin 94 6009 1581
/search/adi/g.php 101 2999 21
/quality-center-tute 67 3292 146
/b 41 3220 119
/bn/at_300.html 12 2174 1108
/getting-started-wit & 2115 872
/sql.html 1 908 908
TOTAL 679 3225 21



Configuration Elements

set up defaults and variables for later use by samplers. o

The figure below shows some commonly used configuration elements in JMeter

CSV Data Set HTTP Cookie Login Config HTTP Request FTP Request
Config Manager Element Defaults Defaults




CSV Data Set Config:

Suppose you want to test a website for 100 users signing-in with different credentials. You
do not need to record the script 100 times! You can parameterization the script to enter
different login credentials. This login information (e.g. Username, password) could be stored
in a text file. JMeter has an element that allows you to read different parameters from that
text file. It is "CSV Data Set Config", which is used to read lines from a file, and split them into

variables.

? & TestPlan
¢ B csv_Dataset_testing
48¢ HTTP Request Defaults
? /‘ Login
41 CsV Data Set Config
Aggregate Report
View Results Tree
i=| WorkBench




This is an example of CSV Data. It's a text file which contains user and password to login your

target website

Eaczmjdantl

username,password, 360
usernamel,passwordl, 360
username’l, password2, 360

W N e

7&:&3], bassfworcﬁl, IBGK

username password  Cookie Length




HTTP request default

This element lets you set default values that your HTTP Request controllers use.

For example,

You are sending 100 HTTP requests to the server google.com

You would have to manually enter server name = google.com for all these 100 requests

Instead, you could add a single HTTP request defaults with the "Server Name or IP" field =

google.com

No need to type 100 times!

HTTP Request Defaults

Name: [HTI'F' Request Defaults

Comments:
~Web Server

|  Timeouts (milliseconds)

Server Name or IP{ |google.com

Port Number: |80 | Connect: {1000 |RESDOI'I$E: |200€_)|

~HTTP Request

Implementation:

Protocol [http]: | | Content encoding:




What is a Test Plan?

Test Plan is where you add elements required for your JMeter Test.

It stores all the elements (like ThreadGroup, Timers etc) and their corresponding settings

required to run your desired Tests.

The following figure shows an example of Test Plan

? & TestPian

? E Thread Group
448 HTTP Request Defaults
Graph Results
#¥ HTTP Request
/*? Response Assertion
Assertion Results
Gf Constant Timer
@ Loop Controller
View Results in Table
/‘ JDBC Request

- !:* Runtime Controller




How to add Elements?

Adding Elements is the essential step to build a Test Plan because without adding elements,
JMeter cannot execute your Test Plan

A Test Plan includes many Elements such as Listener, Controller, and Timer

You can add an element to test plan by right-clicking on a Test Plan and choose new
elements from "Add" list.

Suppose, you want to add 2 elements to Test Plan BeanShell Assertion and Java Request
Default

e Right click Test Plan ->Add ->Assertion->Bean Shell Assertion
* Rightclick Test Plan ->Add ->Config Element ->Java Request Default



You can also remove an unused element

Let's say, you want to remove element "HTTP Request Defaults", select "HTTP Request
Default” -> Right click-> choose Remove from the context menu -> Click Yes to confirm delete

this element on message box

? & TestPlan :
4l HTTP s || HTTP Request Defaults

WorkBench Name: [HTTP Request Defaults

Comments:
| Web Server
Server Name or IP: |Port Number:

| - HTTP Request

Implementation: w | Protocol [hitp]: Content enco

Path: |

Parameters

Send Parameters With the Request:

Mame: WValue




How to Save a Test Plan

Before running a test, you should save your Test Plan first. Saving your Test Plan helps you

avoid unexpected error when running the test plan. Steps to saving Test plan -

1. File -> Save Test Plan as-> a Dialog box display

2. Enter a filename of Test Plan ->click Save == BeanShell Assertion.jmx [C:\.apache-jmeter-zg’\bin\-Lmﬂ-

File Edit Search Run Options Help

mRIEEE

& DB *+|=[4 0w

? 4o TestPlan
488 Java Request Defaults
/™ BeanShell Assertion
EJ WorkBench

Test Plan

Name: |Test Plan
Comments:

Name:




How to Run Test Plan

To run your single or multiple test plans, choose Start (Control + R) from the Run menu item.

3 +[=[5[@Yuls o e = [u]d Al

Thread Group \ Fress Start or Cér/+R to rum a Test

i
r
o

| |Name: [Thread Group

Action to be taken after a Sampler error

@ Continue ) Start Next Thread Loop () Stop Thread () Stop Test () Stop Test Now




When JMeter is running, it shows a small green box at the right-hand end of the menu bar.

oL O0/5 W

The numbers to the left of the green box are the number of active threads / total number of
threads.

To Stop the Test, press Stop button or use short key Ctrl + "

© 0 ' %%




Test Report

When test execution is done, you can get the test report. The test report includes the error
log file, which is saved in jmeter.log, and the test results summary. Here is a sample log file
of JMeter —

e 2013/08/18 08:41:12 INFO - jmeter.JMeter: Copyright (c) 1998-2013 The Apache Software
Foundation

2013/08/18 08:41:12 INFO - jmeter.JMeter: Version 2.9 r1437961

2013/08/18 08:41:12 INFO - jmeter.JMeter: java.version=1.7.0_25

2013/08/18 08:41:12 INFO - jmeter.JMeter: java.vm.name=Java HotSpot(TM) Client VM
2013/08/18 08:41:12 INFO - jmeter.JMeter: os.name=Windows 7

2013/08/18 08:41:12 INFO - jmeter.JMeter: os.arch=x86

2013/08/18 08:41:12 INFO - jmeter.JMeter: os.version=6.1

2013/08/18 08:41:12 INFO - jmeter.JMeter: file.encoding=Cp1252

2013/08/18 08:41:12 INFO - jmeter.JMeter: Default Locale=English (United States)
2013/08/18 08:41:12 INFO - jmeter.JMeter: JMeter Locale=English (United States)

e 2013/08/18 08:41:12 INFO - jmeter.JMeter:

- JMeterHome=C:\Nguyen\Source_code\apache-jmeter-2.9 -



How to Use JMeter for Performance & Load Testing

) Saumpier |
3 send r-equest:;
> €
USerl | HTTP response
Apach}- cyeote : Mw /A
Sl | B | minees
> -
Make copy of samplers USer 2 HTTP response
and runnig them in
sEparare thread
. Sampler n
3 send r-equest:;
> €

USer N | HTTP response

g




Create a Performance Test Plan in JMeter

In this tutorial, we are doing a performance analysis of Google.com for 1000 users

Before testing the performance of target web application, we should determine-

e Normal Load: Average number of users visit your website
e Heavy Load: The maximum number of users visit your website
* Whatis your target in this test?

AddThread || Add Meter || AddGraph || RunTest& |
Group elements result Get Result




Step 1) Add Thread Group

1. Start JMeter
2. Select Test Plan on the tree
3. Add Thread Group

Right click on the "Test Plan" and add a new thread group: Add -> Threads (Users) -> Thread

Gl'OUp File Edit Search Rum Options Help
] =9 ) = _ _ -
@ E M | & 508 | + =4 & & b
&, TestPlan Ll
WorkBeny Add }| Threads (Users) Group
Paste CHrlw Test Fragment # setlp Thread Group
Reset Gui Config Element P tearDown Thread Group
i ]
Open... Timer
Pre Processors » u
Merge
save Selection As Post Processors # | MName:
Assertions »
Save Node As Image Ctl-G .
Listener ]
Save Screen As Image Cirl+Shift-G
Enable
Disable
Togale Ctrl-T
Help




In the Thread Group control panel, enter Thread Properties as follows:

Thread Group

Name: \Threacl Group

Comments:
Action to be taken after a Sampler error

® Contim

Thread Properties
Number of Threads (users): \1 00

Ramp-Up Period (in seconds): |100

Loop Count: | | Forever ‘10

| Delay Thread creation until needed

|| Scheduler

* Number of Threads: 100 (Number of users connects to the target website: 100)
e Loop Count: 10 (Number of time to execute testing)

- e Ramp-Up Period: 100 -



The Thread Count and The Loop Counts are different.

Thread Covnt Loop Count

Connect Om vser
iser | & ¢ N

Connect 1% time
USEY ﬂ. & % 4 Connect 2™ time
VS| &m0
........... - . Connect 107 time
user 100 < v
& WEb Server Weo server
Simulates 100 concurrent users

connecting to target website

Loop Count simulates one user
connecting to target website 10 times

Ramp-Up Period tells JMeter how long to delay before starting the next user. For example, if

we have 100 users and a 100-second Ramp-Up period, then the delay between starting users
would be 1 second (100 seconds /100 users)

HTTP request
Userl

[———]

Delay 1seconds
User2

—

Delay 1seconds
User3

I 202 e — 2 202020202



Step 2) Adding JMeter elements

Now we determine what JMeter elements in this test. The elements are

e HTTP request Default

This element can be added by right-clicking on the Thread Group and selecting: Add -
> Config Element -> HTTP Request Defaults.

| | Thread Group
¥ Logic Controller »

Graph R

 Config Element » Counter
4 HTTP Reqd Copy e Timer » CSV Data Set Config
#*2? Respons Paste Ctrl-V Pre Processors »| FTP Request Defaults
Assertion b, oiicate culsshinc | Sampler »| HTTP Authorization Manager
@ Constant Reset Gui Post Processors | HTTP Cache Manager
View Re o I Assertions »| HTTP Cookie Manager
s Listener B
/% Resutt St§ Open... :
e — ::::Ze!ection . | Forever |100 Java Request Defaults
- >ad creation until n¢ JDBC Connection Configuration
S SR A5 g kO Keystore Configuration




HTTP Request Defaults
Name: [HTTP Request Defaults

Comments:
~Web Server
Server Name or IP: [www.google.com \Port Number: |80 ‘ ‘

 HTTP Request

Right-click on Thread Group and select: Add -> Sampler -> HTTP Request.

? ﬁ Test Plan

¢ [ Thread | Thread Group
i 77 red RO L ] Logic Conroler »
Graph Re Cut Ctrl-X Config Element »
/’ HTTP Red Copy oMb Timer Y | error
#*? Respons{ paste Cirl-v Pre Processors »
Assertior Duplicate Ctri+Shift-C _ Access Log Sampler
Er':'e":t:':! Reset Gui Post P.rocessors » AJPI.3 Sampler
View Ret Remove Delete Assertions *| BeanShell Sampler
2 Result St| Open—. Listener | BSF Sampler

@ WorkBench Merge ] Forever W Debug Sampler

Save Selection As... L —
ead creation until nf

T




Step 3) Adding Graph result

JMeter can show the test result in Graph format.

Right click Test Plan, Add -> Listener -> Graph Results




Step 4) Run Test and get the test result

Press the Run button (Ctrl + R) on the Toolbar to start the software testing process. You will
see the test result display on Graph in the real time.

—_"|||3 |%|=|4'| i’|‘?| ~ |!" » | -0 |‘l|‘i “|$\;«‘||"‘_ZI|B 08 00100 |
Graph Results
| Mame: |craph Resuns |
| Comments:
Wirite results to file | Read from file

F"’“"“" ||L LogMisplay Only: []Errors [ Successes @

Graphs to Display [v] Data || Average Metian Deviation ] Throughpat

Ho of Samples Latest Samphe Average
Dieviation Throughput Median




Jmeter Timers: Constant, Gaussian Random,
Uniform [Example]

What are Timers?

By default, JMeter sends the request without pausing between each request. In that case,
JMeter could overwhelm your test server by making too many requests in a short amount of
times.

Constant Timer:

Constant timer delays each user request for the same amount of time.

Constant Timer

Name: [Constant Timer |

Comments:
Thread Delay (n milliseconds):|300 |




How to use Assertions in JMeter (Response Example)

What is an Assertion?

Assertion help verifies that your server under test returns the expected results.

Response Assertion

¢ a Test Plan
o= Ef" Thread Group
2 hespunse Assertion
i) WorkBench

The response assertion lets you add pattern strings to be compared against various fields of

the server response.

For example, you send a user request to the website http://www.google.com and get the
server response. You can use Response Assertion to verify if the server response contains
expected pattern string (e.g. "OK").




Steps to use Response Assertion

Add Response Add Pattemn to Add Assertion
Asserstl::n { test J [ result J ‘ Run your Test ]




Step 1) Add Response Assertion

Right-Click Thread Group ->Add ->Assertions ->Response Assertion

l@ TestPlan :
¢ B Thread Group | Thread Group
18 177 e RS | Logic Controller »
#% HITPReq 0 X Config Element  »
/™ Response Cony ctrl-C Timer » | Sampler error
= wﬂrlfem" Paste Ctrl-v Pre Processors » | - start Next Thread L
= Duplicate Ci+shinc | Sampler g
Reset Gui Post Processors »
Remove Celete _ BeanShell Assertion
Open_ Listener » BSF Assertion
Merge ICou nt: |_| Forever ﬁ“mzm:ssemrt;on
. ration Assertion
Save Selection As... 2lay Thread creatiol yrmL Assertion
Sevoledo Aslmage  Cuid P JSR223 Assertion
e MD5Hex Assertion
[[Response Assertion
Disable

Size Assertion

T le Ctrl-T i -




Controllers in JMeter: Loop, Simple, Transaction,
Module, Random

What is the Logic Controller?

Logic Controllers let you define the order of processing request in a Thread. It lets you
control "when" to send a user request to a web server. For example, you can use Random
Controllers to send HTTP requests to the server randomly

|
|_| Logic Controllar |




Recording Controller:

JMeter can record your Testing steps; a recording controller is a placeholder to store these
recording steps.

Recording
b controller

User acﬁ\/m.j



Simple Controller:

Simple Controller is just a container for user request.

Simpler controller

@ @

User Yequest| user Yeguest 2

@

\\ User Yeguest 3 /




Loop Controller:

Loop Controller makes the user request run a specified number of times or run forever as
shown in figure:

S ~ Run user

request
request first S?;:on d
time
time

Make vser

Bowiclr B request run s
times third time
forevey
Run user
......... request

- ~ fourth time _



Advanced in JMeter

Jmeter Distributed (Remote) Testing: Master Slave
Co n ﬁ gu ratio n Distributes testing uses client-server model as the figure below:

Master

" JMeter GUI
102.168.0.1

Jmeter-server Jmeter-server jmete;-sm-er
192.168.0.10 192.168.0.11 192.168.0.12
_ Slave 1 _ Slave 2 _ Slave 3




Jmeter Distributed (Remote) Testing: Master Slave
Configuration

¢ Master: the system running JMeter GUI, control each slave.
* Slave: the system running JMeter-server, receive a command from the master and send a

request to a server under test.
* Target: the web server under test, get a request from slaves.

System | ! .‘
[ - J L Run the test J [TmublcshooungJ




HTTP Proxy Server in JMeter: Record Example Script

Recording Controller

? & TestPan 2
Q Test Fragment Ihread GrouP
v I e » Logic Controller ¥ ForEach Controlier »
¢ [ WO:C,,C,, Cut Crl-X Config Element » If Controller
i) W1TP Prd Copy Crl-C Timer » Include Controller
Paste Cirl-v Pre Processors » Interleave Controller Lo
Duplicate cuisshine | Sampler » Loop Controller
Reset Gui Post Processors »| Module Controller —
Remove Delete Assertions »| Once Only Controller
Open... Listener » Random Controller —
Merge oop Count: |_| Foré Random Order Controller
Save Selection As... ] Delay Thread ¢ I Recording Lonirokier |
= Runtime Controller
Save Node As Image Cui-G :] Scheduler Sl Connte
Save Screen As Image Cul+ShinG e
s Throughput Controller
T Transaction Controller
U o St While Controller
Help




HTTP Proxy Server in JMeter: Record Example Script

Set Target Controller where your recorded scripts will be added

HTTP Proxy Server

Name: HTTP Proxy Server
;Cmnments:

Port: [EUEE || Attempt HTTPS Spoofing Optional URL match string:
~Test plan coment

Target Controller] [Test Plan > Thread Group v *ruuplng: Do not group samplers v

Capture HTTP Headers | | Add Assertions | | Regex matching

- HTTP Sampler settings

Type: HTTP Request w [ | Redirect Automatically |v] Follow Redirects Use KeepAlive | | Retrieve All Embedded Res

Content-type filter
Include: |

| Exclude: |




. Start Proxy Server

Return to HTTP Proxy Server, and click the Start button at the bottom. Now your JMeter
proxy server start

HTTP Proxy Server
Name:

HTTP Proxy Server

Comments:
- Global Settings

Port: |BUBU

Test plan content

Target Controller: |Test Plan > Thread Group

w | Grouping: Do not g

Capture HTTP Headers | | Add Assertions | | Regex matching

~HTTP Sampler settings
Type: hd

|| Redirect Automatically Follow Redirects Use KeepAlive |

- Content-type filter
Include: |

| Exclude: |

URL Patterns to Include

URL Patlterns to Include

Add Delete Add from Clipboard




Start your Browser (I used Firefox), choose Tool => Option => Advanced => Network =>
Setting => Enter HTTP proxy as figure below

Options l 3 |

General Tabs Content  Applications Privacy Security  Sync  Advanced

Gene:allData Choices | Network UpdatelEncryption‘

Connection

Configure how Firefox connects to the Internet Settings...

Connection Settings /g

Configure Proxies to Access the Internet
(O No proxy
() Auto-detect proxy settings for this network

(") Use system proxy settings
@ Manual proxy configuration: a
| HTTP Proxy: localhost Port: m; |
|| Use this proxy server for all protocols
SSL Proxy: Port: 0%
ETP Proxy: Port: 0/
SOCKS Host: Port: 0%
() SOCKSv4 @ SOCKSvS

No Proxy for:



After finishing recording, you will see JMeter automatically created a new HTTP request

as the figure below

& TestPian
? E‘ Thread Group '—ITI'P Request -
3§ H1TP Request Defauts | | [Name: |/
? .!,J Recording Controller ;

| |Comments:
o= / :
/' nrpc/p | Web Server
o= Inrpcin :
‘| | Server Name or IP:
fis_fphp HTTP Request
<] s Report
_ Umimary Fepo Implementation: v | Protocol [http]: hitp Methk
iE| WorkBench
.!,J HTTP Proxy Server Path: |/

|| Redirect Automatically Follow Redirects Use KeepAlive

Parameters | Post Body

Send Parameterg

Name:




Click File => Save your Test Plan as
" =~ Apache JMeter (29 r1437961)
[Eile| Edit search Run Options Help

‘ ]
Close Ctri-L J + = & ;
Open Ctri-O a . ,

Merge Test Plan

iuame: Test Plan

Comments:

Save Selection As...
Revert

1 TestPlan.jmx Name!
2 TestPlan_v1.jmx

3 AggregateGraph.jmx

4 RecordingTestPlan.jmx

5 Test Fragment.jmx

6 PerfomanaceTestPlan.jmx

7 Test Plan.jmx

8 Test Fragment.jmx

Exit Ctrl-Q




A Dialog box display => enter a name of your test plan at File Name field => Click Save
Now your Test Plan is saved under name RecordingTestPlan.jmx

= Tet e =)

Savelr: (9 bin v| @(8][c 8815

{

(] examples
[ Test Fragmentjmx
[} Test Planjmx




The Summary Report will show some basic statics

Summary Report

number of
requests per
unit of time

How many
exceptional cases
were found

Name: |Summary Report

A verage response

. time for particular
Write results to file / Read fro HTTP re quest

Comments:

»
Filenamel e l...,......playomy: | Errors [:]Successeyl Configure
Label |#Samples| Average Min Max Std. Dev. | Error % |Throughpul KB/sec | Avg. Bytes

TOTAL - 0| 9223372 |- 0.00 0.00 O/hour 0.00 0

-

See all the

Nimber o minimum, maximum denotes the error
recorded HTTP response time taken percentage in
HTTP request by the HTTP samples request
request request




Save your test result

1. Click Save Table Data to save test result to file

Summary Report
Name: |Summary Report
|
Comments:
Write results to file / Read from file
Filename Browse... | Log/Display Only: | | Errors | | Successes Configure
Label # Samples | Average Min Max Std. Dev. Error % | Throughput| KB/sec Avg. Bytes
/ 100 535 356 782 97.34| 100.00% 1.9/sec 6.37 3506.9
TOTAL 100 535 356 782 97.34| 100.00% 1.9/sec 6.37 3506.9

(] Include group name in label? || Save Table Data | |v] Save Table Header




2. Enter the name of the test result and click Save. Test Result in JMeter is saved in *.csv
format as default

F
& summary.csv “

Save [ bi v @8/ 0) B8l
(9 examples
) summary.csv

File Name: | RecordingTestResult csv
Files of Type: |JMeter [.csy]
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JMeter

Best Practice for JMeter Tests

1) Limit the Number of Threads

» The maximum number of threads you can effectively run with JMeter is 300. This
limit is because of hardware's capabilities. If [Meter is made to run with more
number of threads, the accuracy of timing information will decrease.

2) Using a proxy server
» The Proxy server helps you to abstract out certain common elements from the
recorded samples. Moreover, it is useful features to record your testing.

3) Using variables

» Some test plans need to use different values for different users/threads. For
example, you might want to test a sequence that requires a unique login for each
user. This is easy to achieve using variables.

4) Reduce resource requirement

» The GUI mode consumes a lot of computer memory under heavy load. It causes
performance issues
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Best Practice for JMeter Tests jMeter“"

Reduce resource requirement

The GUI mode consumes a lot of computer memory under heavy load. It causes

performance issues.

There're some tips to reduce resource requirement:

¢ Use non-GUl mode

¢ Disable the "View Result Tree" listener during the Load test. Because it consumes more
memory and causes JMeter running to run out of memory.

¢ Disable all JMeter graphs results

¢ Use the CSV test result format.

® Only save the needed test result. JMeter could take a long time to save very detailed test

results.
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Best Practice for JIMeter Tests

5) Check the JMeter logs

» Any errors in the Test Plan or test execution will be recorded in the log files.
Monitoring the log file help you to find the error early

6) Erase the local path from CSV Data Set Config

» If you are using an existing CSV data file that you created on your local
computer, you should delete the existing local path (Current path of CSV file).
If you don't delete the local path, JMeter cannot find the CSV data file on your
local PC.

1) Follow file naming convention

» Don't save test plan under complex file name, use only
alphanumeric characters


https://www.guru99.com/what-everybody-ought-to-know-about-test-planing.html

Jmeter Alternatives 2020

P SVARTBEAR (o)
LoadNinja &
loader.io

(&)StresStimulus

loadView = BlazeMaeter

by Dotcom-Monitor

. FZ)\ smartmeter.io
£:Batling .aiFunkload
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1. JMeter Website
»_https://jmeter.apache.org/

2. JMeter Tutorial for Beginners: Learn in 7 Days
»_https://www.guru99.com/jmeter-tutorials.html
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